Now that I've gotten a few maintenance releases out the door, I'm starting to feel like r_c's feature set is pretty solid; I think most people's needs should be covered (still a few things left to include, but we're getting there). The next step in improving resource_controller is evolving the API. What better place to hold the discussion than Marc-AndrÃ©'s refactormycode.com?
In the comments of the last release post, Luigi Montanez brought up an issue that's been bugging me since I first released the plugin. Currently, some customizations (before/after callbacks, response blocks, etc) are made with a "DSL"-style API. Some customizations (like alternate model names), however, are made by overriding helper methods. It's not that I don't like overriding methods, but I find the API a bit inconsistent in that way.
Currently, providing an alternate model name looks like this...
class PostsController < ResourceController::Base private def model_name 'blog_post' end end
It would be really neat, though, if it was possible to set the model_name the same way you set the flash...
class PostsController < ResourceController::Base model_name :blog_post end
Please, come join the discussion at RmC, and put some of your ideas on the table for resource_controller's API.